We are closed until COVID-19 restrictions are lifted - there is no shipment and limited support during this period

The following information is for the EMANT300, EMANT380

.NET Framework 4 Client profile is not supported by our 2008 or earlier controls

Question: I am using Visual C# Express 2010. While trying out program 11.1 Basic Statistics, after referencing the Emant300.dll and EmantCntrl.dll as instructed in the manual, I get the following error:

The referenced assembly "EmantCntrl" could not be resolved because it has a dependency on "System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" which is not in the currently targeted framework ".NETFramework,Version=v4.0,Profile=Client". Please remove references to assemblies not in the targeted framework or consider retargeting your project.

Answer: The default .NET Framework 4 Client profile is not supported by the version of EmantCntrl which is shipped for Visual Studio 2008 or earlier. In order to make it work, change the target framework to .NET 4 Framework (not the client profile)

1) From the VC# 2010 menu, select Project -> YourProjectName Properties
2) Change the Target Framework to .NET 4 Framework